Compatibility

Each version of the Contentsquare Flutter SDK will be linked to specific, fixed versions of each native SDK. In order to make that clear, here is a compatibility table to consider when choosing your version of the bridge (refer to the Flutter SDK Changelog to know what the changes are for each version).

Contentsquare Flutter SDK VersioniOS SDK VersionAndroid SDK VersionMinimum Flutter Version
3.2.04.23.04.19.02.8.0
3.1.04.23.04.19.02.8.0
3.0.04.22.14.18.12.8.0
2.3.04.21.04.17.02.8.0
2.2.04.20.04.16.02.8.0
1.3.24.18.04.15.02.8.0
1.3.1 (deprecated)4.18.04.15.02.8.0
1.3.04.17.04.14.02.8.0
1.2.04.13.04.13.12.8.0
1.1.04.13.04.13.12.8.0
1.0.14.13.04.13.12.0.0
1.0.04.13.04.11.02.0.0
0.5.34.13.04.11.02.0.0
0.5.24.13.04.9.02.0.0
0.5.14.13.04.9.02.0.0
0.5.04.13.04.9.02.0.0
0.4.24.12.04.8.02.0.0
0.4.14.11.04.8.02.0.0
0.4.04.11.04.7.02.0.0
0.3.04.11.04.7.02.0.0
0.2.34.10.14.7.02.0.0
0.2.24.10.04.3.02.0.0
0.2.14.6.04.3.02.0.0
0.2.04.6.04.3.02.0.0
0.1.04.3.04.1.02.0.0